You are here: Foswiki>Gnumed Web>WindowsInstallerDependenciesRu (17 Mar 2013, IvanLykov)EditAttach

Зависимости установщика GNUmed на Windows

"Клиентам Bare" потребуются другие программные компоненты для установки

Следующие компоненты являются частью большого, но простого пакета GNUmed, и нужны только для отдельной инсталляции при установке пакета GNUmed для "клиента bare". Из следующих компонентов должен быть установлен в первую очередь более крупный пакет Python, поэтому дождитесь полной загрузки и установите его до других. Для каждого компонента можно кликнуть все из параметров по умолчанию 'Далее' и 'OK'. В сжатом виде папки, содержащие эти же требования, для вашего удобства предоставлены здесь.

  1. Python 2.6.6 является языком программирования, на котором GNUmed написан ( установить первым)
  2. psycopg2 (2.2.1) необходим для подключения к базе данных PostgreSQL
  3. egenixmxTools предоставляет полезную поддержку для обработки даты и времени
  4. версия юникод wxPython 2.8.12 прорисовывает экраны и элементы управления GUI
  5. PIL 1.1.7 для управления изображением в цифровом архиве GNUmed
  6. Twainmodule мост Twain Python для подключения сканера... Примечание: до тех пор, пока они обеспечиваются фактической установкой, все, что нужно сделать, это взять файл *.pyd и поместите его в каталог lib/site-packages для python (например, c:\python2.6)
  7. Python-Win32 расширения Python для Windows

Только устаревшие примечания:

История версий доступна здесь, информация devel упакована здесь

v0.2.6 to 1.1.4:

  1. Python 2.5.4 является языком программирования, на котором GNUmed написан ( установить первым)
  2. psycopg2 (2.0.8) необходим для подключения к базе данных PostgreSQL
  3. egenix mxTools предоставляет полезную поддержку для обработки даты и времени
  4. wxPython 2.8.11 unicode version прорисовывает экраны и элементы управления GUI
  5. PIL 1.1.6 для управления изображением в цифровом архиве GNUmed
  6. Twainmodule мост Twain Python для подключения сканера... Примечание: до тех пор, пока они обеспечиваются фактической установкой, все, что нужно сделать, это взять файл *.pyd и поместите его в каталог lib/site-packages для python (например, c:\python2.5)

v0.2.3 to 0.2.5.1 - outdated

v0.2.0 - outdated

v0.1 - ancient

  • v0.1: Если запускаете английскую версию Windows и не видите зелёного окна входа в GNUmed в течение 20 секунд, может понадобиться редактировать (нажать правой мышкой "Edit") файл "batch" GNUmed и разместить два вхождения программы в PROGRA~1. Сохраните изменения и попробуйте снова пункт Start menu.
    • Как только это сделаете для окна входа в систему, перейдите к разделу руководства пользователя Регистрация в системе.
Topic revision: 17 Mar 2013, IvanLykov
 
Download.png
This site is powered by the TWiki collaboration platformCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding Foswiki? Send feedback
Powered by Olark