You are here: Foswiki>Gnumed Web>MandrivaLinuxRu (15 Feb 2013, IvanLykov)EditAttach

Как установить и запустить GNUmed на MandrivaLinux 2007.1 и более поздних

  • для клиентской части имеется несколько пакетов rpm на www.mandrivauser.de (также должны работать с 2007.1) благодаря Florian aka doktor5000 из MUde-rpm-team

  • для серверной части имеется сложный и легкий способ. Легкий состоит в использовании серверного пакета rpm package 'gnumed-server'

Установка и запуск GNUmed на Mandriva

  • Руководство по установке находится в Wiki от Mandrivauser.de

В качестве альтернативы предоставления нейтральный способ заключается в использовании сценария для сервера

  • Сначала правильно установите зависимости и установите PostgreSQL:
    • установите зависимости
      • urpmi task-gnumed
    • установите базу данных
      • service postgresql start
      • passwd postgres
      • su - postgres
      • psql template1
      • create user web_user;
      • create database web_database owner web_user;
      • \q
      • exit
      • service postgresql restart
      • psql -U web_user web_database

  • теперь, либо используйте сценарий установки, либо сделайте это вручную:
    • скачайте и распакуйте gnumed-server
    • выполните начальную установку сервера GNUmed
      • cd GNUmed-v7/server/bootstrap
      • sh bootstrap-latest.sh

Mandrake Linux 9.1* от Michael Bonert <michael.bonert@utoronto.ca> (Wed Apr 2 00:17:07 EST 2003)

  • CVS (из Mandrake CD): cvs-1.11.5-1mdk
  • postgresql (из Mandrake CD): postgresql-7.3.2-5mdk
  • postgresql-devel-7.3.2-5mdk
  • postgresql-python-7.3.2-5mdk
  • postgresql-server-7.3.2-5mdk
  • postgresql-pl-7.3.2-5mdk
  • pgaccess-0.98.8.20030117-2mdk # приятно иметь
  • postgresql-docs-7.3.2-5mdk # приятно иметь
  • wxPythonGTK-py2.2-2.4.0.1-1.i386.rpm)
  • egenix-mx-base-2.0.4-py2.2_1.i386.rpm)
  • pyPgSQL
    • Этот пакет может быть установлен, либо из исходного кода, либо из RPM. Сообщите мне по электронной почте (bonerti AT mie DOT utoronto DOT ca) об RPM.
    • Перед установкой pyPgSQL убедитесь, что имеется следующее (с Mandrake CD):
    • libpython2.2-devel-2.2.2-6mdk
Topic revision: 15 Feb 2013, IvanLykov
 
Download.png
This site is powered by the TWiki collaboration platformCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding Foswiki? Send feedback
Powered by Olark